Yuval Pecht

Notification of end of support for Microsoft Internet Explorer 8 browser

Discussion created by Yuval Pecht Employee on Dec 10, 2014

As a Samanage administrator of an organization with users who have logged into Samanage using Internet Explorer 8 (IE8), we want to alert you of an important change to the support of this Microsoft browser.

What is changing?

Microsoft has announced that they will end support for IE8 on Windows XP in January 2015. Samanage will also stop supporting this older browser by March 2015.

In addition, beginning in March 2015, some features/functionality may no longer work in IE8 browsers. Bugs or performance issues that appear only when using IE8 will not be investigated or fixed by Samanage after this date.

Why are we ending support for IE8?

As we evaluate which browsers to support, we consider which ones will give our users the best experience and enable us to focus on areas that will add the most value for customers. There are four key reasons that drove this decision:

  1. IE8 is less secure. Trust and security are incredibly important to us at Samanage. There have been multiple security vulnerabilities discovered in these older browsers over the years, so we are upholding our commitment to Trust by ending support for these less secure browsers.
  2. IE8 is not HTML5 compatible. IE8 was released in 2009. This browser does not support the rich internet apps our customers have come to expect, including HTML5, which is the new industry standard and the technology we are investing in moving forward. It supports mobile devices; doesn?t rely on plug-ins; and provides a faster customer experience.
  3. Microsoft will stop supporting IE8 on Windows XP in January 2015. For more information on Microsoft?s plans, please see their website: http://www.microsoft.com/en-us/windows/endofsupport.aspx
  4. Our customers are moving to newer browsers. Less than 0.5% of our customers are using IE8. Our customers are trending towards newer browsers, and we want to develop features that best serve our customer community.

What action do I need to take?

We are giving you advanced notice to ensure you have as much time as possible to plan for alternative strategies. We strongly recommend that you and your company?s IT administrators upgrade to one of our supported browsers prior to March 2015.

Our list of currently recommended browsers (as of Jan. 2015):

  • Microsoft Internet Explorer versions 9 and above
  • Mozilla Firefox, most recent stable version
  • Google ChromeTM, most recent stable version
  • Apple Safari, most recent stable version Mac OS X

What will happen if I take no action?

 

While users may still be able to access the service from IE8 after March 2015, new and/or existing features and functionality may no longer work in these browsers. In addition, bugs or performance issues that appear only when using IE8 will not be investigated or fixed by Samanage after this date.

 

How can I get more information?

 

Samanage Support Team is always available to answer any questions you may have about this change. We appreciate your business and look forward to working with you during this transition to support your success.

Outcomes